Autor Thema: Startproblem mit der Monogame-Version  (Gelesen 967 mal)

Offline mhvg220

  • Mitglied
Startproblem mit der Monogame-Version
« am: 08.04.2018, 16:16:47 »
Hallo zusammen,

ich wollte auch mal die Monogame-Version von OR ausprobieren, beim Start werde ich aber mit der auf dem Bild zu sehenden Fehlermeldung "beglückt". Woran liegt das?

Offline Colonia60

  • Mitglied
Re: Startproblem mit der Monogame-Version
« Antwort #1 am: 11.04.2018, 18:14:38 »
Hallo zusammen,

ähnliches Problem mit der OR Monogame-Version ( 4075 ) habe ich auch auf meinem Win 7-System,
die "d3dcompiler_47.dll kann nicht gefunden werden.
Der Fehler verschwindet aber auch nach dem Hereinkopieren der beanstandeten Datei in
Windows/System32 , SysWOW64 und ins Hauptverzeichnis des Monogame-Ordners ( in diesem Fall OR4075_MG) nicht.







Offline Richie57

  • Administrator
  • *****
  • Let the good times roll!
Re: Startproblem mit der Monogame-Version
« Antwort #2 am: 12.04.2018, 12:19:47 »
Hallo zusammen,

da die MonoGame-Version von OR bei mir völlig problemlos läuft, kann ich Euere Fehlermeldungen leider schlecht nachvollziehen, sorry!

Ich habe deshalb meine Downloads, die irgendwie im Zusammenhang mit OpenRailsMG stehen könnten, kritisch durchgesehen.
Daneben habe ich auch die Registry nach der angemeckerten d3dcompiler_47.dll durchsucht; diese ist sowohl in System32 als auch in SysWOW64 vorhanden, dagegen aber nicht im OR-MG-Verzeichnis ... Sackgasse also!
In meinen Downloads desselben Zeitraums bin ich dann auf die Datei "OpenAL32.dll" gestoßen, die sich sowohl in der Registry (System32 und SysWOW64) als auch im Hauptordner von OR-MG wiedergefunden hat.
Eventuell liegt hier der Hund begraben? Ich kann es leider nicht mehr nachvollziehen ...  :-\

Einen Versuch ist aber allemal wert!
Vielleicht liest ja auch Carlo hier mit, damit er ein wenig Licht ins Dunkel bringen kann. ;)

Viele Grüße
Richie
"... Menschlichkeit und Politik schließen sich im Grunde immer aus. Beide sind nötig, aber beiden zugleich dienen, ist kaum möglich.
Politik fordert Partei, Menschlichkeit verbietet Partei."

Hermann Hesse

Offline Colonia60

  • Mitglied
Re: Startproblem mit der Monogame-Version
« Antwort #3 am: 12.04.2018, 17:32:48 »
Um noch etwas mehr Licht in das Dunkel hereinzubringen,
habe ich die Fehlermeldung im Anhang beigefügt.
An der OpenAL32.dll liegt es anscheinend nicht.

MfG
Uwe

Offline mhvg220

  • Mitglied
Re: Startproblem mit der Monogame-Version
« Antwort #4 am: 12.04.2018, 18:22:01 »
Hier das, was unter "Details" zu lesen ist

Offline Richie57

  • Administrator
  • *****
  • Let the good times roll!
Re: Startproblem mit der Monogame-Version
« Antwort #5 am: 12.04.2018, 19:15:08 »
An der OpenAL32.dll liegt es anscheinend nicht.

Aha ... das tut mir leid! :(

Was mir sonst noch aufgefallen ist, ist dass ich mir auch einen Satz MonoGame.dll´s heruntergeladen habe.
Ob es ursächlich damit zusammenhängt, kann ich jetzt nicht sagen, jedenfalls tauchen diese dll´s auch im Fehlerbericht auf.
Ich habe das dll-Packet auf meinen Server hochgeladen:

www.richies-rail-world.de/openrails/MonoGame.zip

Ich hoffe, dass Ihr wenigstens damit irgendwie weiterkommt! ;)

Viele Grüße
Richie
"... Menschlichkeit und Politik schließen sich im Grunde immer aus. Beide sind nötig, aber beiden zugleich dienen, ist kaum möglich.
Politik fordert Partei, Menschlichkeit verbietet Partei."

Hermann Hesse

Offline Colonia60

  • Mitglied
Re: Startproblem mit der Monogame-Version
« Antwort #6 am: 13.04.2018, 14:11:44 »
Hat leider auch nix gebracht  :(

In der Fehlermeldung ist mir noch eine mehrfach aufgeführte Pfadangabe aufgefallen,
die nicht zu meinem System gehört und mit
D:\ADRIANA\Carlo\OR_Work\Monogame_New\Source\RunActivity\Viewer3D anfängt.

Ob DAS vielleicht mit dem Fehler zusammenhängt?
Wäre eine weitere Möglichkeit.

MfG
Uwe


Offline Richie57

  • Administrator
  • *****
  • Let the good times roll!
Re: Startproblem mit der Monogame-Version
« Antwort #7 am: 13.04.2018, 14:56:03 »
Moin Uwe,

irgendwie kommt mir die Geschichte langsam ziemlich seltsam vor!
Ich habe doch auch nichts anderes heruntergeladen als Du und Markus ... und ich bekomme keine Fehlermeldungen! ???

Die Pfadangabe auf die Du dich beziehst stammt wohl aus dem Arbeitsordner von Carlo und referenziert eine fehlende Funktionalität ...
Viewer3D ist ein Bestandteil der runactivity.exe ... aber was daran nicht stimmen sollte, vermag wahrscheinlich nur Carlo zu klären.
Vielleicht schickst Du ihm einfach mal eine PM. ;)

Alternativ kann ich Euch einfach mal meine MonoGame-Version anbieten, wobei ich mir nicht sicher bin, ob das soviel bringt. Aber, wenn gewünscht, dann gerne. ;)

Ich grübele einfach noch ein bißchen weiter ...

Viele Grüße
Richie
"... Menschlichkeit und Politik schließen sich im Grunde immer aus. Beide sind nötig, aber beiden zugleich dienen, ist kaum möglich.
Politik fordert Partei, Menschlichkeit verbietet Partei."

Hermann Hesse

Offline Colonia60

  • Mitglied
Re: Startproblem mit der Monogame-Version
« Antwort #8 am: 14.04.2018, 15:48:21 »
Hallo Richie,

ich habe mal etwas weitergesponnen und auf einem neuen zweiten Rechner
( AMD FX 4300 Quadcore 3,8 GHz, 8 GB Speicher ,NVidia GTX1050 Ti ,Win 10 )
 das "normale" OpenRails samt Content und anschließend die Monogame-Version aufgespielt.

Das Ergebnis:
Ganz im Gegensatz zum alten System läuft das Teil,sogar recht gut.
Zwei Sachen sind mir gleich aufgefallen,
bei der Monogameversion habe ich mehr Fps als beim "normalen" OR,
auch die Schattendarstellung scheint feiner zu sein.
Hier mal zwei Bilder zum Vergleich,
das erste aus X4103,das zweite aus Monogame:



Im Anhang meine OR-Anzeigeeinstellungen.

Viele Grüße
Uwe










Offline Richie57

  • Administrator
  • *****
  • Let the good times roll!
Re: Startproblem mit der Monogame-Version
« Antwort #9 am: 14.04.2018, 17:23:33 »
Hallo Uwe,

das freut mich jetzt aber wirklich! :)
Wir wissen zwar jetzt immer noch nicht wirklich, worin die anfänglichen Schwierigkeiten begründet waren, aber was soll´s ... :pardon

Eines ist mir noch noch aufgefallen:
Aus welchem Grund hast Du bei der normalen Sichtweite 4000m eingetragen?
Die meisten Objekte sind für 2000m oder weniger gebaut worden, also bringt die höhere Sichtweite nicht viel, außer dass das System unnötig belastet wird und somit die Fps auch entsprechend niedrig sind. Die Fps sollten eigentlich bei einem neuen Rechner wesentlich höher sein.
Aber O.K., wenn´s für Dich so passt, schön! ;)

Wesentlich mehr Realitätsnähe bringt die Einstellung im experimentellen Teil "Maximale Sichtbarkeit aller Objekte zum Horizont erweitern" ... kostet allerdings auch ein paar wenige Fps ...

Viele Grüße
Richie

P.S.: Die Optionen Modell-Instanzverarbeitung und Vertikale Synchronisation würde ich auch noch wegklicken; besonders letztere Option bringt eigentlich nichts und ist ressourcenhungrig!
"... Menschlichkeit und Politik schließen sich im Grunde immer aus. Beide sind nötig, aber beiden zugleich dienen, ist kaum möglich.
Politik fordert Partei, Menschlichkeit verbietet Partei."

Hermann Hesse

Offline mhvg220

  • Mitglied
Re: Startproblem mit der Monogame-Version
« Antwort #10 am: 14.04.2018, 21:09:29 »
Leider will es einfach nicht laufen, die normalen experimentellen Versionen gehen problemlos. Wohin müssen denn die .dll aus der Monogame.zip?

Offline Richie57

  • Administrator
  • *****
  • Let the good times roll!
Re: Startproblem mit der Monogame-Version
« Antwort #11 am: 14.04.2018, 23:04:49 »
Wohin müssen denn die .dll aus der Monogame.zip?

In das OR-MG-Verzeichnis (Hauptebene)!

Viele Grüße
Richie
"... Menschlichkeit und Politik schließen sich im Grunde immer aus. Beide sind nötig, aber beiden zugleich dienen, ist kaum möglich.
Politik fordert Partei, Menschlichkeit verbietet Partei."

Hermann Hesse

Offline mhvg220

  • Mitglied
Re: Startproblem mit der Monogame-Version
« Antwort #12 am: 15.04.2018, 15:41:23 »
Ändert leider nichts. :'(
Irgendwas bei Windows muss bei mir anders sein als bei allen anderen.

Offline DukeHB

  • Mitglied
Re: Startproblem mit der Monogame-Version
« Antwort #13 am: 21.04.2018, 22:16:50 »
Moin,

hänge jetzt auch fest. Selbige Problem, wie oben schon beschrieben.
Arbeite auch mit W10. Habe XNA, Monogame 3.6 und TortoiseSVN aufgespielt.

Zum Verständnis:
Die OR4075_MG läuft ohne Patch schon nicht, auch nicht mit den .dlls aus der Monogame.zip. Fehlermeldung wie im ersten Post.

Habe versucht auf ElvasTower den Thread nachzuvollziehen, aber irgendwas entgeht mir da, denn die Fehlermeldung tauchte da auch auf, aber die Lösung konnte ich nicht nachvollziehen.

Richie kannst du beschreiben, wie du Schritt für Schritt vorgegangen bist?
Habe vermutlich ein Denkfehler drin, irgend etwas übesehe ich.

Beste Grüße

Offline Richie57

  • Administrator
  • *****
  • Let the good times roll!
Re: Startproblem mit der Monogame-Version
« Antwort #14 am: 22.04.2018, 12:39:21 »
Moin DukeHB,

ich glaube nicht, dass Du einen Denkfehler gemacht hast!
Irgendetwas an dieser Problematik erschließt sich mir auch nicht, denn ich habe weder MonoGame noch Tortoise SVN resident auf meinem Rechner; lediglich diverse XNA-Versionen tummeln sich in verschiedenen Windows-Verzeichnissen herum ...  :-\

Ich habe definitiv nichts anderes als die OR-MG4075.zip, die diversen dll´s und OpenAL32.dll heruntergeladen, wobei ich sagen muss, dass ich die beiden letzteren Downloads eigentlich nur sicherheitshalber heruntergeladen habe.
Wenn ich mich recht entsinne, hatte ich beim ersten Start der MonoGame-Version auch eine Fehlermeldung, die ich einfach weggeklickt habe; anschließend lief OR-MG ohne weiteres Meckern anstandslos durch. Bis jetzt ist diese Meldung auch nie mehr aufgetreten (knock on wood!!!)!

Leider habe ich keine Ahnung, wie Win10 so richtig tickt, da ich (immer noch) Win7 Ultimate 64bit als Betriebssystem verwende.
Eine Möglichkeit zur Behebung der Probleme wäre evtl. der Weg, den Uwe (Colonia60) gegangen ist ... und wenn´s dann auch noch geklappt hat!  :pardon
Einen Versuch wäre es wert.

Der richtige Ansprechpartner in dieser causa ist aber Carlo (Carlosanit)!
Ich würde ihn einfach mal anschreiben und das Problem ausführlich schildern, denn das hilft auch der Weiterentwicklung.

Ich wünsche Dir und allen anderen einen schönen und sonnigen Restsonntag
Richie

P.S.: Im Anhang noch die Dateiliste meines OR_MG-Verzeichnisses.
« Letzte Änderung: 22.04.2018, 12:55:17 von Richie57 »
"... Menschlichkeit und Politik schließen sich im Grunde immer aus. Beide sind nötig, aber beiden zugleich dienen, ist kaum möglich.
Politik fordert Partei, Menschlichkeit verbietet Partei."

Hermann Hesse